Play&Plug/data-exchange : File submission blocked for single partnership

Incident Report for Wakam Services

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 11:39 CEST

Investigating

We are currently investigating the issue
Posted Sep 10, 2025 - 10:52 CEST
This incident affected: Partner Data Exchange.